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� Mapinfo Professional consente di eseguire complesse analisi 
geografiche come la creazione di territori, di collegarvi con database 
remoti, di incorporare nelle vostre applicazioni oggetti mappa, di 
creare mappe tematiche che evidenzino i dati che vi interessano e altro 
ancora.



Uno sguardo generale al desktop mapping

� Il desktop mapping è uno strumento di analisi dei dati nel quale i dati 
statistici acquistano forma grafica e possono essere rappresentati su 
una mappa.



Che cos’è il desktop mapping?

� Desktop mapping è una definizione utilizzata per i programmi che 
consentono, utilizzando un personal computer, di organizzare e gestire 
dati utilizzando come base una mappa computerizzata.

� Per poter utilizzare il sw, qualunque esso sia, si devono sempre fare tre 
operazioni:

– acquistare la mappa computerizzata della zona d’interesse
– inserire in un database i dati che intendete rappresentare sulla mappa
– collegare i dati alfanumerici alla mappa



� A questo punto potete cominciare a fare le vostre elaborazioni. E’ in 
questa fase che il software diventa determinante per consentirvi di 
realizzare due obiettivi:

– ottenere la rappresentazione che volete
– ottenerla in modo semplice e veloce



Cosa il desktop mapping può fare per me?

� La rappresentazione dei dati su una mappa fornisce una nuova base per 
la loro analisi e dunque nuove possibilità di comprensione, ovvero:

� visualizzazione + analisi = comprensione



Devo cambiare metodo di lavoro per usare
Mapinfo?

� Mapinfo è concepito per adattarsi facilmente a qualsiasi ambiente di 
lavoro. Saranno quindi solo i risultati a cambiare, non il metodo.

� Mapinfo è compatibile con Windows e Office.
� Potete usare i dati che già possedete, nel loro formato (fogli di lavoro, 

database, tabelle ASCII), oppure potete crearli direttamente in
Mapinfo.

� Potete utilizzare tutte le migliaia di mappe disponibili con Mapinfo, 
oppure importarle da altre applicazioni, o crearle con Mapinfo.

� Mapinfo unisce alla forza delle procedure di gestione dei database 
(incluse le ricerche sql) la forza visiva delle mappe.
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� Supponete di possedere uno o più archivi di dati. Come inserire questi 
dati in Mapinfo e rappresentare le informazioni che contengono su una 
mappa? Come combinare tra loro informazioni contenute in file 
differenti e come visualizzarle in maniera definitiva?

� Questo capitolo vi darà una solida comprensione di concetti, 
componenti e strumenti.



Come organizzare i dati e le mappe: le tavole

� Mapinfo organizza tutte le sue informazioni, siano esse testuali o 
grafiche, sotto forma di tavola.

� Questa tavola è costituita da un minimo di due file separati: il primo 
contiene la struttura dei dati (nomefile.tab), il secondo i dati (in 
formato interno: nomefile.dat, o esterno: dBase, Lotus, Exel o ASCII).

� Ai dati possono essere associati oggetti grafici (vettoriali); in tal caso 
al file .tab saranno associati altri due file:

� nomefile.map: descrive gli oggetti grafici (coordinate di punti, vertici
di poligoni, ecc)

� nomefile.id: consente il collegamento tra dati e oggetti
� Se la tavola è anche indicizzata, per consentire la ricerca di oggetti 

sulla mappa, un quinto file è presente: nomefile.ind



Come portare i vostri dati in Mapinfo

� Una volta letti i dati in formato esterno Mapinfo crea un file .tab; da 
questo momento verranno trattati come file nativi.

� Se però successivamente viene modificata la struttura del file o anche 
solo i dati, si deve sostituire la definizione della tavola.

� Il comando Apri serve anche per aprire e visualizzare immagini raster, 
che devono essere calibrate. Anche ad esse Mapinfo associa un file 
.tab.



Come costruire le mappe: i layer

� Ogni mappa può essere costituita da più tavole, ciascuna delle quali 
rappresenta un layer.

� Ogni tavola può apparire in più finestre Mappa, da sola o con altre 
tavole.



Come rappresentare le tavole di Mapinfo: le 
finestre

� Le finestre Mappa presentano le informazioni sotto forma di mappe, 
per visualizzare il lato geografico dei dati.

� Le finestre Dati presentano le informazioni sotto forma di tabelle 
(come un database tradizionale).

� Le finestre Grafico presentano le informazioni sotto forma di grafici, 
limitatamente ai dati numerici.

� La Finestra Impaginazione consente di unire insieme mappe, grafici e 
tabelle per comporre stampe professionali.

� I dati possono essere rappresentati contemporaneamente in modo 
diverso su diverse finestre; le selezioni ed i cambiamenti apportati ad 
una di queste vengono immediatamente riflessi sulle altre.



Come associare i vostri dati alla mappa: il
geocode

� Per associare i dati alle mappe, bisogna assegnare delle coordinate ai 
record. Per fare questo è necessario disporre di una tavola di Mapinfo
che contenga degli oggetti grafici con relativi nomi. Questa operazione 
di associazione si chiama Geocode.



Gli oggetti della mappa

� Esistono quattro tipi base di oggetti:
� Zone: oggetti chiusi che coprono determinate aree (poligoni, ellissi => 

confini comunali)
� Punti: coppie di coordinate X,Y che rappresentano singole 

localizzazioni di dati.
� Oggetti lineari: oggetti aperti che coprono determinate distanze (linee, 

archi => strade)
� Testi: descrizioni di oggetti o mappe (titoli, etichette)

� Un layer può contenere oggetti di tipo diverso.



Gli strumenti per lavorare

� Mapinfo punta molto sulla facilità d’uso.
� Gli strumenti sono rappresentati da icone (raggruppate in cinque

gruppi distinti) che servono per accedere ai comandi e alle funzioni di 
uso più frequente.

� L’interfaccia può essere personalizzata facilmente.

� Strumenti standard
� Strumenti principali
� Strumenti di disegno
� Strumenti Mapbasic
� Strumenti ODBC



Mapinfo in azione: il processo logico

� Lavorando in Mapinfo si gode di un’ampia libertà, ma si devono pur 
sempre compiere alcuni passi obbligati:

� Aprire le tavole con le mappe e i dati che interessano
� Combinare le mappe tra loro, per ottenere una rappresentazione a strati
� Vedere in tabelle i dati, per decidere su cosa basare l’analisi
� Associare i dati alle mappe
� Selezionare i dati che interessano (con criteri geografici o 

alfanumerici)
� Rappresentare i dati sotto forma di mappe tematiche
� Personalizzare le mappe e renderle leggibili
� Creare stampe di alta qualità, per dare rilevanza ai risultati del vostro 

lavoro
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� Questo capitolo si propone di aiutarvi a cominciare a capire e usare le 
funzioni base di Mapinfo.



Avvio di Mapinfo

� Doppio clic sulla relativa icona nel Program Manager di Windows.
� La Finestra di Avvio contiene le seguenti opzioni:
� - ripristina la sessione precedente
� - apri l’ultima Area di lavoro usata
� - apri un’Area di lavoro
� - apri una Tavola



Personalizzazione di Mapinfo

� Il menu Preferenze vi consente di specificare un gran numero di 
parametri che regolano il funzionamento generale di Mapinfo:

– sistema
– mappa
– legenda
– avvio
– indirizzi
– directory



Apertura di una tavola

� File > Apri
� Appare la finestra di dialogo Apri Tavola con le varie opzioni.
� Per selezionare un percorso di default, scegliete il menu Directory 

dentro Opzioni > Preferenze.
� Potete aprire ulteriori tavole, e aggiungere ulteriori layer alla mappa. 

Potete aprire anche la tavola solo come tabella dati. 



� Se specificate Automatica come Vista preferita, Mapinfo visualizza il 
contenuto delle tavole in maniera intelligente:
– se alla tavola sono associati oggetti grafici, la tavola viene aperta sotto 

forma di mappa
– se una mappa è già aperta, e la seconda tavola può essere rappresentata 

nella stessa finestra, Mapinfo la aggiunge come nuovo layer, altrimenti 
apre una nuova finestra

– se alla tavola non sono associati oggetti grafici, essa viene aperta sotto 
forma di tabella

� Si può anche aprire una tavola senza vederla in una finestra.



Visualizzazione di una tavola in una mappa

� Finestra > Mappa
� Le finestre Mappa servono a rappresentare la parte geografica delle 

tavole.
� In una mappa si possono visualizzare contemporaneamente dati di più 

tavole:
� in questo caso, ogni tavola viene rappresentata in un layer.
� Quando è attiva una finestra Mappa, sulla barra dei menu diventa

attivo il menu Mappa.

� Gli oggetti delle tavole possono essere rappresentati con stili e colori 
diversi in funzione di quello che rappresentano; per illustrarne il 
significato si possono creare le legende, tematiche e cartografiche.



Visualizzazione dei dati di una tavola in una 
tabella

� Finestra > Dati
� La finestra Dati consente la visione e la gestione dei dati nella forma a 

righe e colonne, tipica dei database e dei fogli di lavoro.
� Quando è attiva una finestra Dati, sulla barra dei menu diventa attivo il 

menu Dati.
� Usando lo strumento Seleziona potete:

– selezionare uno o più record (quadratino a sinistra)
– ridimensionare e spostare colonne
– modificare i dati



Visualizzazione dei dati in un grafico

� Finestra > Grafico
� La finestra Grafico consente di confrontare i dati tra loro tramite un 

grafico.
� Quando è attiva una finestra Grafico, sulla barra dei menu diventa 

attivo il menu Grafico.



Selezioni

� Le selezioni danno luogo a  tavole provvisiorie su cui si possono fare 
molte delle operazioni che si eseguono normalmente su tavole 
permanenti, perciò una tavola di selezione può essere:
– visualizzata in una finestra Dati, Mappa, Grafico o Impaginazione
– tagliata, copiata, incoporata in altra tavola o applicazione
– usata per modificare una parte di una tavola
– usata come base per ulteriori selezioni



� File > Salva Copia come
� Per trasformare tavole provvisorie in permanenti

� NB: se chiudete una tavola base, si perdono tutte le tavole provvisorie 
ad essa associate.



� Selezioni dallo schermo:
� Seleziona, Oggetti entro Rettangolo, Oggetti entro Raggio, Oggetti 

entro Poligono, Seleziona Tutto.



� Selezioni attraverso interrogazioni:
� Seleziona, Seleziona SQL.



� Si possono combinare selezioni dallo schermo e interrogazioni.
� Mapinfo chiama Selection l’ultima selezione effettuata; non appena la 

rappresentate su una finestra prende il nome di Query1, Query2, ecc.



Visualizzazione dei dati associati agli oggetti

� Per vedere il record di dati associato ad un oggetto grafico, selezionare 
lo strumento principale Informazioni (icona con la “i”) e fate clic 
sull’oggetto.

� I dati vengono visualizzati in una specifica finestra, la Finestra 
Informazioni.

� Se fate clic in un punto ove vi siano più oggetti, nella finestra appare 
l’elenco degli oggetti con il layer di appartenenza. Se il layer è 
modificabile, i dati appaiono riquadrati nella finestra Informazioni, e si 
possono modificare.



Stampa

� File > Stampa
� Per stampare una finestra Mappa o grafico.
� Per stampe più sofisticate si deve ricorrere alla finestra Impaginazione, 

ove si possono combinare grafici, mappe e tabelle.

� L’output può essere indirizzato a stampante, plotter o file.



Chiusura delle tavole

� File > Chiudi
� Si possono chiudere più tavole contemporaneamente, siano esse 

visualizzate o meno.
� Con la chiusura di una tavola vengono chiuse automaticamente tutte le 

rappresentazioni che ne sono state fatte
� Se chiudete una tavola che appare in una finestra mappa con altre 

tavole, essa viene rimossa dalla finestra che però rimane aperta.



Copia e cambiamento di nome delle tavole

� Tutti i file di una tavola si devono trovare nella stessa directory, e 
devono avere lo stesso nome (diversa estensione).

� Per fare una copia di una tavola:
� File > Salva copia come

� Per rinominare una tavola:
� Tavola > Mantieni Tavole > Rinomina

� Cambiare nome ad una tavola ha effetto sulle aree di lavoro che ne 
fanno uso.

� Ricordarsi che una tavola è costituita da due o più file.



Esportazione file

� File > Esporta finestra
� Per esportare la finestra Mappa in altri formati di file, ed utilizzarla in 

altre applicazioni:
– *.bmp
– *.wmf
– *.emf
– *.jpg
– *.png
– *.tif
– *.psd



Aree di lavoro

� Mapinfo consente di conservare l’impostazione del lavoro tra una 
sessione e l’altra, in modo da non dover ricominciare ogni volta
dall’inizio:

� File > Salva Area di Lavoro (filename.wor)
� L’area di lavoro è un file di testo editabile che contiene traccia delle 

tavole e finestre aperte, dimensioni, stili, campiture, ecc.
� File > Apri Area di Lavoro

� NB.: Salvando un’area di lavoro non salvate i cambiamenti fatti alle 
tavole i cui nomi sono registrati nell’area di lavoro



Aree di lavoro

� Opzioni > Preferenze > Avvio
� per salvare automaticamente l’impostazione su cui si sta lavorando in 

un’area di lavoro chiamata MAPINFOW.WOR
� questa può poi essere caricata all’avvio di Mapinfo.

� STARTUP.WOR è il nome chiave di una particolare area di lavoro con 
cui può essere lanciato Mapinfo. 
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� Questo capitolo descrive le varie preferenze e le funzioni che esse 
controllano.

� Le preferenze consentono di modificare numerosi parametri di default 
di Mapinfo e di personalizzare alcuni aspetti del programma.



Accesso alle preferenze

� Opzioni > Preferenze
� Le preferenze sono raggruppate secondo le seguenti categorie:

– Sistema
– Finestra mappa
– Finestra legenda
– Avvio
– Ricerca indirizzi
– Directory
– Impostazioni output
– Stampante
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� Questo capitolo descrive la relazione tra tavole e mappe, mostrandovi 
come sia possibile utilizzare il concetto di layer per ottenere il livello 
di dettaglio che desiderate.



Organizzazione delle mappe in layer

� Su una finestra Mappa possono apparire più tavole.
� Ogni tavola può essere immaginata come un foglio trasparente.



Procedure generali per la creazione di una 
finestra Mappa

� Per creare una finestra Mappa costituita da più layer potete seguire 
diverse procedure:



� Tavola non aperta:
� File > Apri
� Selezionare le tavole e la vista preferita (Automatica).



� Tavola aperta ma non visualizzata:
� Finestra > Mappa
� Selezionare le tavole nell’ordine desiderato.
� Mappa > Controllo Layer
� Selezionare la tavola da aggiungere alla finestra Mappa.



� Creazione di una copia identica di una mappa:
� Mappa > Clona Mappa
� Crea una nuova finestra Mappa che è una copia identica della finestra 

Mappa attiva. 
� Si può così creare una diversa vista della mappa, o imporre un diverso

tematismo.
� Un altro modo di duplicare una mappa è quello di usare lo strumento 

Trascina Finestra Mappa (icona con mano e maniglia) - drag&drop da 
una finestra mappa ad un’altra.



� Isolamento di una porzione di mappa
� Mappa > Definisci e Ritaglia zona
� (oppure l’icona con le forbici)
� Consente di selezionare una parte di mappa e di visualizzarla da sola.
� Mappa > Annulla Ritaglia
� Per rivedere l’intera mappa.



La finestra di dialogo Controllo Layer

� Mappa > Controllo Layer
� (oppure l’icona con i fogli sovrapposti)
� Consente di decidere per ogni mappa quali layer siano visibili, 

modificabili e selezionabili, e per quali siano visibili le etichette.
� Consente di riordinare i layer, aggiungerli o rimuoverli, cambiare i loro 

attributi, quelli delle etichette e delle mappe tematiche .



Manipolazione dei layer

� Visualizzazione dei layer:
� L’attributo visibile della finestra di consente di controllare se un layer

sia visibile sulla mappa (spunta sulle caselle che si trovano nella prima 
colonna, rappresentata dall’icona dell’occhio).

� Potete selezionare più layer insieme tramite i tasti Shift e Control.



Ordine dei layer in una finestra Mappa

� I layer sono disposti nella mappa secondo l’ordine in cui appaiono 
nella lista del Controllo layer. L’ordine può essere cambiato 
(spostando anche più layer contemporaneamente) tramite i comandi Su 
e Giù, o con un drag&drop.

� Il layer di personalizzazione non può essere spostato.
� L’ordine dei layer ha effetto sugli strumenti di selezione: gli oggetti 

selezionati appartengono al layer superiore.



Ordine degli oggetti in un layer

� Mapinfo non vi consente di controllare l’ordine di disegno di oggetti 
sovrapposti appartenenti allo stesso layer.



Aggiunta e rimozione di layer

� Posso aggiungere o rimuovere uno o più layer contemporaneamente 
tramite gli omonimi pulsanti.



Opzioni di visualizzazione

� Tramite il pulsante Stili/Zoom o con un doppio clic sul nome del layer, 
accedo alla finestra di dialogo Opzioni di Visualizzazione.



Modalità di visualizzazione

� Il modo in cui appaiono gli oggetti sulla finestra Mappa può essere 
cambiato tramite l’opzione Ignora lo stile di default. Posso modificare:

� tipo linea
� contorno e campitura delle zone
� tipo di simbolo associato ai punti
� tipo di carattere dei testi (non delle etichette)



Limiti di visualizzazione dei layer della 
Mappa

� La sezione Limiti di Zoom vi consente di visualizzare un layer solo 
quando il livello di zoom della mappa ricade in un intervallo definito.
Layer differenti della stessa mappa possono avere diversi limiti di 
zoom.



Direzioni, nodi e centroidi

� Con la finestra Opzioni di visualizzazione, potete infine decidere se 
vedere:

� la direzione delle linee (utile per capire la direzione dei civici associati)
� i nodi che costituiscono gli oggetti (utili per modificare gli oggetti)
� la posizione dei centroidi (dove vengono ancorate etichette e grafici 

associati alle zone)



Layer modificabili e selezionabili

� Quando un layer è modificabile, potete apportare modifiche agli 
oggetti grafici di quella tavola.

� Potete modificare solo un layer per volta.
� Su un layer selezionabile posso usare gli strumenti di selezione, 

etichetta e informazione.
� Potete rendere selezionabili più layer contemporaneamente.
� Per rendere selezionabile o modificabile un layer, fate clic sul suo 

nome nella finestra di dialogo Controllo Layer e attivate le relative 
opzioni.



� Un layer modificabile è anche selezionabile.
� Gli strumenti di selezione del menu Interroga sono attivi 

indipendentemente dal fatto che il layer sia selezionabile o meno.
� Per selezionare oggetti appartenenti al secondo layer selezionabile, fare 

Control clic.
� Se fate clic con lo strumento Informazioni su una zona dove ci sono 

più oggetti, ne viene mostrato l’elenco.



Il Layer di personalizzazione

� Ogni finestra mappa contiene un Layer di personalizzazione, che si 
sovrappone a tutti gli altri.

� Serve a contenere quegli oggetti che non fanno parte della mappa vera 
e propria, ma ne aiutano la comprensione.

� Non può essere spostato, né rimosso; può essere reso modificabile e 
selezionabile.

� Le altre opzioni non sono disponibili per il Layer di personalizzazione.
� Oggetti e testi sono disegnati in proporzione al livello di zoom della 

mappa.
� Per rimuovere oggetti: Mappa > Vuota Layer di personalizzazione
� Gli oggetti possono essere salvati in un’area di lavoro, o su un layer

esistente, o creare un nuovo layer: Mappa > Salva Oggetti di 
Personalizzazione



Etichette degli oggetti appartenenti ai layer

� Potete visualizzare automaticamente le etichette in un layer tramite 
l’attributo Auto Etichette della finestra Controllo layer.

� Potete visualizzare le etichette di singoli oggetti usando lo strumento 
Etichetta (icona con l’etichetta).

� In ogni caso potete controllare lo stile delle etichette con la finestra di 
dialogo Controllo Etichette (da Controllo layer).



Layer senza giunture

� Usate o create una mappa con layer senza giunture per trattare un 
gruppo di tavole base come se si trattasse di un’unica tavola (una 
tavola base non può essere raster).

� La struttura di ogni layer senza giunture include il nome del percorso 
di ogni tavola base, più una descrizione che sostituisce il nome della 
tavola (pseudonimo).



� Viene trattato in modo leggermente diverso rispetto ad una normale 
tavola:

� Controllo layer. Tutto tranne Tematismo. Non lo si può rendere 
modificabile.

� Strumento Informazioni. Si possono ottenere su un qualunque oggetto 
di una tavola base.

� Strumenti di selezione. Si possono selezionare insieme solo oggetti di 
una stessa tavola base.

� Dati della tavola. Si può visualizzare ogni tavola base su una finestra 
dati (e aprirne più d’una contemporaneamente).



� Potete stabilire i percorsi seguiti da Mapinfo per la ricerca delle tavole 
base: Opzioni > Preferenze > Directory.

� Per creare i vostri layer senza giunture dovete utilizzare 
un’applicazione MapBasic, e disporre di tavole omogenee, che abbiano 
la stessa proiezione e lo stesso numero di colonne.



� Per avviare l’applicazione Tavole senza giunture (Seamless Manager):
� Tools > Gestisci tools
� fate clic su caricato 
� fate clic su OK; un sottomenu Tavole senza giunture viene aggiunto al 

menu Tools



� Per cambiare la struttura di un layer senza giunture bisogna prima 
disattivarlo:

� Tools > Tavole senza giunture > Disattiva senza giunture
� Sulla mappa al posto degli oggetti grafici appaiono dei riquadri che 

definiscono i limiti di ciascuna tavola base. Nella finestra Dati appare 
l’elenco delle tavole componenti.

� Per riattivare un layer senza giunture :
� Tools > Tavole senza giunture > Attiva senza giunture



Mappe tematiche e immagini raster come
layer

� Le mappe tematiche create in Mapinfo vengono trattate come un 
nuovo layer, esattamente uguale agli altri.

� Possono essere modificate facendo clic su Tematismo oppure con 
Mappa > Modifica Mappa Tematica.

� Anche le immagini raster, una volta calibrate, sono trattate come layer
vettoriali.
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� Con Mapinfo potete visualizzare e localizzare i vostri dati su una 
mappa. Questa è una delle ragioni di essere principali di Mapinfo, 
consentirvi di vedere la distribuzione geografica dei dati per aiutarvi a 
prendere decisioni migliori. Tuttavia, per fare questo, è necessario 
prima creare un oggetto grafico per ogni record. Questo processo
prende il nome di geocode.



Associazione di coordinate ai record: il
geocode

� Per visualizzare i dati su una mappa, dovete prima assegnare le 
coordinate X e Y ad ogni record. Posso farlo associando alle 
informazioni descrittive di una tavola le informazioni geografiche di 
un’altra (tavola di riferimento) alla quale sono state già associate delle 
coordinate X e Y.

� Questa procedura si chiama Geocode.



Metodi di geocode

� Geocode per indirizzo
– Mapinfo associa gli indirizzi (Numero Civico, Nome della Strada, 

Appartamento e altre info) contenuti nei vari record del database ad una 
tavola che rappresenti una mappa stradale e assegna le coordinate x e y dei 
segmenti della mappa ai record.

� Geocode per zona (comune, provincia, stato, CAP, ecc.)
– Mapinfo legge nella vostra tavola il nome della zona cui il record si 

riferisce, e la ricerca nella tavola di riferimento: se la ricerca ha successo, 
assegna le coordinate X e Y del centroide della zona al record.

� Geocode per punti
– Mapinfo legge nella vostra tavola il nome del punto cui il record si 

riferisce, e lo ricerca nella tavola di riferimento: se la ricerca ha successo, 
assegna le coordinate X e Y del punto al record.



Tre domande da porsi prima di eseguire il
geocode

� Che tipo di informazioni contiene il mio database?
– indirizzi, nomi di comuni, CAP?
– Ci sono delle informazioni potenzialmente ambigue? (es.: omonimie nei 

toponimi, ecc)

� Con che tipo di mappe devo lavorare?
– Il livello di dettaglio delle mappe deve corrispondere a quello dei dati.

� Quanto deve essere geograficamente accurato il posizionamento dei 
miei dati sulla mappa?
– A volte può bastare il centroide (tematismi).



Procedure generali di geocode

� Tavola > Geocode
� Nella finestra di dialogo Geocode inserire le seguenti informazioni:

– nome della tavola a cui assegnare le coordinate
– colonna della stessa tavola con le informazioni descrittive da usare per 

l’associazione
– nome della tavola di riferimento
– colonna della tavola di riferimento contenente gli oggetti grafici.
– scelta del tipo di geocode:

� automatico: l’associazione ha luogo solo per le corrispondenze esatte (non 
richiede l’intervento dell’utente, ma non è efficace)

� interattivo: all’utente viene chiesto di risolvere i casi dubbi



� È consigliabile eseguire prima il geocode automatico, poi quello 
interattivo per associare i record rimanenti.



Posizionamento di punti geocode

� Quando si esegue il geocode per indirizzo è possibile specificare alcuni 
aspetti della posizione risultante dei punti in relazione alla strada.

� È possibile specificare l’offset del punto dalla strada e l’inset del punto 
dalle estremità della strada.



Il geocode per indirizzi: i possibili problemi e 
le tecniche per arrivare ad una percentuale di 

successo vicina al 100%
� Raramente al primo tentativo vengono assegnate le coordinate a tutti i 

record.
� Le informazioni possono non corrispondere esattamente, possono 

esserci abbreviazioni non riconosciute da Mapinfo.



Errori di digitazione

� In modo interattivo, Mapinfo offre una lista di nomi simili alternativi.
� Se gli errori sono numerosi, può convenire modificare i dati della 

tavola prima del geocode.



Numeri civici inesatti nel file dati

� Ogni tratto di strada contiene informazione dei propri numeri civici.
� In modo interattivo, Mapinfo offre una lista di possibili numeri civici.
� Mapinfo può anche selezionare automaticamente il civico più vicino.



Abbreviazioni non riconosciute

� Quando effettua il geocode per indirizzi, Mapinfo legge un file di 
abbreviazioni (MAPINFOW.ABB) che può essere modificato in modo 
da adattarsi alle esigenze dell’utente.



Indirizzi ambigui

� Lo stesso indirizzo può esistere in comuni diversi; conviene allora 
perfezionare la ricerca utilizzando le zone.



Una nota sul Geocode interattivo

� Con il geocode interattivo NON VENGONO MODIFICATI I DATI.. 
Semplicemente si istruisce il programma affinchè legga informazioni 
diverse.



Codici risultato

� Ad ogni tentata associazione Mapinfo attribuisce un codice risultato 
interno, tramite il quale è possibile conoscere il motivo di ogni 
mancata associazione.



Geocode manuale

� È il processo che vi consente di posizionare i vostri dati facendo clic 
sulla mappa con il mouse.

– Aprite la tavola con la mappa di riferimento
– aprite la tavola con i dati e aggiungetela alla mappa di riferimento
– se non è mappabile: Tavola > Mantieni tavole > modifica struttura
– rendete modificabile il layer della tavola da georiferire
– visualizzate la finestra dati della tavola da georiferire
– selezionate un record sulla finestra dati
– fate clic sulla barra del titolo della finestra mappa
– selezionate lo strumento Simbolo
– fate clic sulla mappa dove volete posizionare il nuovo punto
– ripetete per ogni punto e salvate la tavola



Visualizzazione dei dati sulla mappa

� Dopo aver effettuato il geocode posso rappresentare i punti sulla 
mappa:

� Finestra > Mappa oppure Mappa > Controllo Layer > Aggiungi.
� L’operazione di geocode assegna PERMANENTEMENTE ai record le 

coordinate.
� Non dovete fare alcun salvataggio dopo il geocode.



Localizzazione dei dati sulla mappa

� Interroga > Ricerca
� Per individuare sulla mappa oggetti o record, indicandoli con un

simbolo.
� La finestra di dialogo Ricerca è molto simile alla finestra Geocode.
� Il comando Ricerca può essere eseguito solo su un campo indicizzato 

di una tavola.



Creazione di punti

� Se avete un database nel quale le coordinate sono esplicite (cioè in due 
campi del db), potete vedere i dati sulla mappa senza dover fare il
geocode.

� aprire la tavola
� Tavola > Crea punti

� Se avete già fatto il geocode della tavola, la funzione Crea Punti non 
modifica quelli già creati.

� Una volta creati si possono visualizzare come di consueto.



Creazione di punti da file Excel

� File > Apri tavola (specificando tipo *.xls)
� specificate l’intervallo del foglio di lavoro da leggere
� i dati del foglio di lavoro vengono visualizzati in una finestra Dati
� assicuratevi che le colonne con le coordinate siano di tipo numerico
� Tavola > Crea punti



Dispersione di punti

� In seguito ad un geocode per località potreste avere molti punti 
sovrapposti. È possibile disperderli in una piccola area .

� Tools > Gestisci tools
� selezionate Disperdi
� Tools > Gestisci tools > Disperdi
� Fate una copia di salvataggio prima di alterare la tavola
� Selezionate il metodo tra quelli disponibili

– sistematicamente N,S,E,O,NE,SO,NO,SO
– sistematicamente in senso orario
– casualmente
– casualmente con linee di richiamo



Estrazione di longitudine e latitudine da una 
tavola di punti

� Interroga > Seleziona SQL
� In Seleziona colonne usate le funzioni CentroidX e CentroidY in 

aggiunta a quelle della tavola base che volete replicare
� Nella tavola chiamata … mettete il nome della nuova tavola che verrà 

creata



Scrittura di longitudine e latitudine nella 
stessa tavola contenente i punti

� Tavola > Mantieni tavole > Modifica struttura
� Aggiungete due nuove colonne definendole decimale 13,6

� Tavola > aggiorna colonna
� Tavola da aggiornare e tavola da cui leggere coincidono
� Valore CentroidX(obj)

� Tavola > aggiorna colonna
� Tavola da aggiornare e tavola da cui leggere coincidono
� Valore CentroidY(obj)



Scrittura di coordinate in un sistema di 
proiezione differente da longitudine/latitudine

� Opzioni > Mostra finestra MapBasic
� Visualizzate in una finestra Mappa la tavola da cui volete estrarre le 

coordinate
� Mappa > Opzioni > Scegli proiezione
� Procedete come nei casi precedenti con le funzioni CentroidX e 

CentroidY



Operazioni comuni dopo il geocode

� Dopo un’operazione di geocode possono restare alcuni record senza 
alcun oggetto associato

� Per trovarli: Interroga > Seleziona
� la condizione da porre è NOT OBJ



Annullamento del geocode

� Tavola > Modifica struttura
� Disattivare l’opzione Tavola Mappabile affinchè Mapinfo rimuova 

tutti gli oggetti grafici associati alla tavola.

� Per annullare parzialmente un geocode:
� visualizzare la tavola su una finestra mappa e renderla modificabile
� selezionare gli oggetti
� Modifica > Cancella solo Oggetti



Per saperne di più ...

� Uso dei codici risultato
� Il file abbreviazioni
� Modifica del file abbreviazioni
� MAPINFOW.ABB

� vedere manuale
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9 - Selezioni

� La selezione di record e oggetti è una delle operazioni più frequenti in
Mapinfo. In questo capitolo ci proponiamo di fare un discorso generale 
sulle selezioni e di descrivere l’uso degli strumenti di selezione grafica. 
Le selezioni tramite interrogazione saranno trattati nel capitolo 
successivo.



Cos’è una selezione?

� La vera forza di Mapinfo consiste nella sua capacità di raggruppare e 
organizzare i dati.

� Selezione: un’ estrazione di dati raggruppati sulla base di una o più 
variabili.

� La creazione di queste selezioni prende avvio da una serie di 
interrogazioni.



� Le selezioni danno luogo a  tavole provvisorie su cui si possono fare 
molte delle operazioni che si eseguono normalmente su tavole 
permanenti, perciò una tavola di selezione può essere:
– visualizzata in una finestra Dati, Mappa, Grafico o Impaginazione
– tagliata, copiata, incorporata in altra tavola o applicazione
– usata per modificare una parte di una tavola
– usata come base per ulteriori selezioni



� Mapinfo chiama Selection l’ultima selezione effettuata; non appena la 
rappresentate su una finestra Dati, mappa o grafico, prende il nome di 
Query1, Query2, ecc.

� NB: non potete disegnare oggetti su un layer che contiene i risultati di 
una ricerca, anche se lo rendete modificabile.

� NB: se chiudete una tavola base, si perdono tutte le tavole provvisorie 
ad essa associate.



� File > Salva Copia come
� Per trasformare tavole provvisorie in permanenti.



Selezioni dallo schermo:

� Seleziona, Oggetti entro Rettangolo, Oggetti entro Raggio, Oggetti 
entro Poligono, Seleziona Tutto.



Selezioni attraverso interrogazioni:

� Seleziona, Seleziona SQL.

� Si possono combinare selezioni dallo schermo e interrogazioni.



Selezioni grafiche

� Potete effettuare selezioni grafiche dallo schermo se i layer sono 
selezionabili (finestra Controllo layer).

� Mapinfo evidenzia gli oggetti usando i simboli scelti con:
� Opzioni > Preferenze > Finestra Mappa



� Se il layer è anche modificabile, Mapinfo evidenzia anche i vertici del 
rettangolo d’ingombro dell’oggetto.

� Se più layer sono selezionabili, verranno evidenziati gli oggetti del 
livello superiore.

� Se volete selezionare oggetti appartenenti a layer inferiori, tenete 
premuto il tasto Control.



Annullamento della selezione di oggetti o di 
record

� Per annullare la selezione di un oggetto o un record all’interno di un 
gruppo di oggetti o record selezionati, si ricorre al tasto Shift
(maiuscole).

� Per annullare la selezione di tutti gli oggetti, fare clic in un punto vuoto 
della mappa o Interroga > Annulla Selezione.



Strumenti di selezione

� Palette degli strumenti principali:
– seleziona
– oggetti entro raggio
– oggetti entro rettangolo
– oggetti entro poligono



Seleziona

� Vi permette di selezionare oggetti uno per volta.
� Per aggiungere o togliere oggetti alla selezione, avvalersi del tasto

Shift



Oggetti entro raggio

� La selezione avviene su tutti gli oggetti appartenenti al primo layer
selezionabile il cui centroide cade dentro la circonferenza disegnata.

� Il valore del raggio del cerchio viene visualizzato nell’angolo inferiore 
sinistro dello schermo.



Oggetti entro rettangolo

� La selezione avviene su tutti gli oggetti appartenenti al primo layer
selezionabile il cui centroide cade dentro il perimetro del rettangolo 
disegnato.



Oggetti entro poligono

� La selezione avviene su tutti gli oggetti all’interno di qualunque zona 
della Mappa (provincia, comune, ecc.).

� Devono essere selezionabili sia il layer contenente gli oggetti che il
layer contenente il poligono; devono essere il primo e secondo tra i
layer selezionabili.

� Facendo clic all’interno di una zona, vengono selezionati tutti gli 
oggetti dell’altro layer che vi sono contenuti.

� Il tasto Control consente di selezionare oggetti dalle zone dei layer
successivi.



Altri metodi di ricerca

� Potete disegnare poligoni personalizzati ed operare selezioni 
all’interno di essi.

� Potete creare poligoni con il comando Buffer, che serve per tracciare 
zone intorno a linee, punti o altre zone.

� Per vedere l’elenco dei record selezionati: Finestra > Dati > Selection
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10 - Selezioni tramite interrogazioni

� In questo capitolo vedremo come Mapinfo può selezionare gli oggetti 
in maniera tradizionale, e cioè tramite interrogazioni sul database. Due 
comandi di Mapinfo consentono la selezione di oggetti mediante 
interrogazioni: Seleziona e Seleziona SQL. La prima è più semplice, la 
seconda più potente.



Selezioni tramite interrogazioni

� Con il comando Seleziona potete formulare interrogazioni su una 
tavola di dati.

� Con il comando Seleziona SQL potete fare di più:
– derivare nuove colonne con valori calcolati da altre colonne
– aggregare dati (produrre subtotali)
– combinare più tavole in una tavola di esito
– estrarre dalla tavola di esito solo le righe e le colonne che interessano



Che cos’è Seleziona?

� Interroga > Seleziona
� Consente di effettuare interrogazioni su una tavola.
� Selezionare record ed oggetti in base a condizioni soddisfatte dai loro 

attributi.
� Creare una tavola di esito, visualizzabile in una finestra dati, mappa o 

grafico.



� Se la tavola è visibile in una finestra dati o in una finestra mappa, il 
risultato della selezione viene evidenziato, e in ogni caso viene creata 
una tavola provvisoria chiamata Selection.

� Potete rappresentare questa tavola in una finestra dati, mappa o
grafico; non appena lo fate, essa assumerà il nome QueryN.

� Per salvarla in modo permanente: File > Salva Copia come



Creazione di espressioni

� Per eseguire un’interrogazione, dovete creare un’espressione, ovvero 
un’istruzione logica.

� Esistono due metodi per creare un’espressione:
– scriverla direttamente
– avvalersi dell’opzione Guida e della relativa finestra di dialogo 

Espressione.

� Essa offre tre opzioni utilizzabili per la costruzione di un’espressione:
– colonne
– operatori
– funzioni



� Colonne
– Mostra tutte le colonne della tavola da cui si sta operando la selezione.

� Operatori
– Mostra l’elenco degli operatori matematici e logici che possono essere 

usati per creare l’espressione.

� Funzioni
– Mostra l’elenco delle funzioni matematiche disponibili.
– Funzioni: Operazioni matematiche che producono un valore come 

risultato dell’elaborazione di uno o più parametri.
– In Mapinfo, le funzioni usano come argomenti i dati delle colonne.



Fasi della selezione

� Interroga > Seleziona
– Specificate la tavola da cui selezionare i record
– Create l’espressione logica
– Selezionate, se volete, la colonna in base a cui ordinare la selezione
– Attivate, se volete, la casella Mostra Risultati

� Mapinfo visualizza la nuova tavola su una nuova finestra dati e le 
assegna il nome QueryN (a meno che non specifichiate un nome nel 
campo Scrivi risultati nella tavola).



Creazione di una nuova tavola contenente 
parte dei dati di un file

� Dopo aver selezionato gli oggetti che vi interessano, utilizzate il 
comando

� File > Salva copia come
� salvando la Selection come una nuova tavola.



Cos’è Seleziona SQL?

� Con Seleziona SQL potete creare tavole di esito contenenti 
informazioni che nella tavola base sono solo implicite.

� Interroga > Seleziona SQL
� Appare la finestra di dialogo.



� 1 - “dalle tavole”
� Prima di tutto dovete specificare le tavole (una o più) da usare

nell’interrogazione.
� Solo dopo aver selezionato le tavole è possibile selezionare le colonne 

ad esse relative.



� 2 - “Seleziona colonne”
� La seconda operazione consiste nel selezionare le colonne della tavola 

di esito risultante.
� È possibile prendere colonne da diverse tavole e crearne di nuove sulla 

base di funzioni matematiche (colonne derivate).
� Ho a disposizione tre insiemi di funzioni: Operatori (+, and, ...), 

Aggregati (sum, avg, ...) e Funzioni (abs, area, ...).
� Per assegnare un nome alle colonne, basta aggiungerlo di seguito alla 

loro definizione, separato da un blank e racchiuso tra doppi apici.
� L’asterisco le seleziona tutte.



� 3 - “dove”
� La terza operazione consiste nel porre delle condizioni sui dati delle 

colonne di cui al passo precedente.



� 4 - “raggruppa per”
� Seleziona SQL permette di aggregare dati di più record, in base al 

contenuto di una colonna.



� 5 - “ordina per”
� Posso specificare l’ordine in cui compaiono i risultati, in base ad una o 

più colonne di una delle tavole base.



� 6 - “nella tavola chiamata”
� Posso battezzare la tavola di esito come preferisco, se non voglio che 

le venga assegnato un nome dal sistema.



� 7 - <Verifica>
� Tramite l’omonimo pulsante posso verificare la correttezza della mia 

impostazione.
� Posso scegliere l’opzione Mostra risultati.



Salvataggio delle query

� Ogni tavola creata con Seleziona, Seleziona SQL o con gli strumenti di 
selezione, è provvisoria.

� Per salvarla:
� File > Salva copia.

� È anche possibile salvare l’istruzione che crea una query come tavola 
query di Mapinfo:

� File > Salva query
� Una tavola query è composta da due file:

– *.QRY
– *.TAB



Salvataggio delle query nelle aree di lavoro

� Potete anche salvare le query in un’area di lavoro.
� Quando aprite un’area di lavoro che contiene una query, questa viene 

eseguita, e ogni finestra contenente una query viene visualizzata.
� Al contrario di quanto avviene quando salvate una query in una 

Tavola, non viene creato un file separato contenente la query.

� N.B.: le query vengono salvate in un’area di lavoro se è attiva 
l’opzione “Salva query nelle aree di lavoro” nella finestra di dialogo:

� Opzioni > Preferenze > Avvio.
� Questa opzione è attiva per default.



Modelli di interrogazione

� Potete salvare un’istruzione di interrogazione e ricaricarla in seguito. 
Particolarmente utile per:

– applicare la query a versioni diverse della stessa tavola
– applicare la query a tavole diverse ma con la stessa struttura

� < Salva Modello >
� Viene creato un file *.QRY nella directory:
� Opzioni > Preferenze > Directory > Query salvate.

� N.B.: viene salvata l’istruzione, non il risultato.

� < Carica modello >
� Per riutilizzare l’istruzione precedentemente salvata.



Colonne derivate

� Una colonna derivata è una colonna di una tavola di esito i cui 
contenuti sono generati dall’applicazione di un’espressione ai valori 
contenuti in altre colonne già esistenti.

� Potete anche creare colonne derivate basate sulle funzioni di 
aggregazione count, sum, …

– per es.: sum(pop_91) restituisce la popolazione complessiva italiana



Creazione di pseudonimi per le colonne

� Quando Mapinfo crea una colonna derivata, le attribuisce come nome 
l’espressione da cui deriva.

� Per attribuire alla colonna uno pseudonimo, è necessario inserirlo alla 
destra dell’espressione, separato da un blank e racchiuso tra doppi 
apici.



Aggregazione dei dati

� Quando aggregate dei dati, eseguite un’operazione matematica su tutti 
i valori di una colonna in tutti i record della tavola.

� Mapinfo cerca tutti i record che in una colonna specificata presentano 
lo stesso valore, e crea un record relativo a questo insieme di record.

� L’operazione è ripetuta per ogni diverso valore della colonna 
specificata.

� Dovete perciò specificare:
– come saranno raggruppati i record
– come saranno aggregati i dati

� count, sum, average, wtavg, max, min



Le condizioni di ordinamento e 
raggruppamento

� Potete raggruppare i risultati di un’interrogazione sulla base del 
contenuto di una particolare colonna in modo che ogni riga della tavola 
di esito contenga il dato complessivo relativo al gruppo di record 
omogenei della tavola base.

� Specificate la colonna da utilizzare per aggregare i dati nella casella 
“raggruppa per”.

� Potete anche richiedere a Mapinfo, tramite la casella “ordina per”, di 
ordinare i risultati in base al contenuto di una o più colonne.



Unione di tavole tramite Seleziona SQL

� Mapinfo vi consente di effettuare selezioni su più tavole 
contemporaneamente, per avere in un’unica tavola dati letti o derivati 
da diversi database.

� Mapinfo deve poter collegare le informazioni contenute nei record 
delle varie tavole.

� Potreste avere una tavola mappabile con i soli oggetti grafici ed una 
tavola con dati alfanumerici relativi agli stessi oggetti.

� Quando lavorate su tavole diverse, indicate nella casella “dove” il 
modo in cui associare i record delle diverse tavole.
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� Le mappe tematiche costituiscono un efficace metodo di analisi dei 
dati. Attribuendo forma grafica ai dati statistici li rendono 
rappresentabili su una mappa. Tendenze e andamenti difficili da 
cogliere sui tabulati diventano più chiari se trasferiti su mappe 
tematiche.

� In Mapinfo potete creare mappe tematiche usando diversi metodi, 
molto diversi tra loro: le varie opzioni, fra le quali la possibilità o meno 
di avere mappe multi-variabile o punti di inflessione, vi consentono di 
disporre di molte vie per analizzare i dati.



Cos’è una mappa tematica?

� Creare una mappa tematica significa assegnare diversi colori, tipi di 
campitura, tipi di linea o simboli agli oggetti di una mappa, in
relazione al loro valore.

� Con Mapinfo potete creare 6 diversi tipi di mappa tematica:
� intervalli, grafici a barre, grafici a torta, simboli e scalari, densità di 

punti e valori singoli.
� Tramite i grafici si possono differenziare gli oggetti in base al 

contenuto di più variabili contemporaneamente.

� In una mappa tematica si possono utilizzare valori non numerici.



Pianificazione della creazione di una mappa 
tematica

� Fasi di creazione della mappa tematica
� 1 Scegliete la tavola su cui realizzare il tematismo.
� 2 Selezionate un tipo di tematismo.
� 3 Selezionate dalla mappa il layer da tematizzare.
� 4 Selezionate la colonna con i dati (o create un’espressione matematica 

con dati di più colonne). I dati possono essere anche letti da un’altra 
tavola.

� 5 Specificate i parametri di calcolo relativi al tipo di tematismo scelto.
� 6 Specificate gli attributi grafici.
� 7 Personalizzate la legenda.
� 8 OK per vedere la mappa.
� 9 File > Salva Area di Lavoro per salvare la mappa tematica.



Variabili tematiche

� La quantità da rappresentare si dice variabile tematica.
� Può essere il contenuto di una colonna o il risultato di un’espressione.



Dove leggere i dati

� I dati utilizzati possono trovarsi nella stessa tavola da tematizzare o in 
un’altra tavola.



Uso di dati contenuti nella stessa tavola

� Nella finestra di dialogo Crea mappa tematica, selezionate la tavola e 
la colonna con i dati.



Uso di dati letti da un’altra tavola

� L’opzione Unisci (in fondo all’elenco delle colonne del layer da 
tematizzare) consente di leggere dati da un’altra tavola e di scriverli in 
una colonna temporanea del layer da tematizzare.



Collegamento tra le tavole

� Esistono due modi per collegare le tavole:
– se le tavole hanno un campo contenente un’informazione comune, lo si 

può usare per effettuare l’associazione.
– se entrambe le tavole contengono oggetti grafici, e gli oggetti dell’una 

sono contenuti in quelli dell’altra, il collegamento può essere geografico.



Aggregazione dei dati letti da un’altra tavola

� Nell’opzione Calcola bisogna specificare il modo in cui Mapinfo deve 
raggruppare i dati prima di associarli agli oggetti del layer da 
tematizzare.

� Le opzioni di calcolo sono:
– Count, Sum, Avg, WtAvg, Max, Min



Layer tematici

� Quando create una mappa tematica, Mapinfo aggiunge un nuovo layer
alla mappa, sopra al layer su cui il tematismo si basa.



Layer separati

� La separazione dei layer tematici dal layer su cui si basano rende le 
mappe tematiche flessibili e potenti.

� Potete avere più layer tematici per ogni layer di base e visualizzarli 
contemporaneamente.

� Potete creare mappe tematiche a due variabili



Ordine dei layer tematici

� L’ordine dei layer è importante per una loro corretta visualizzazione:
� 1 - grafici e simboli
� 2 - densità di punti
� 3 - intervalli per colore o dimensione
� 4 - intervalli con tutti gli attributi
� 5 - a griglia
� 6 - layer di base



Visualizzazione dei layer tematici

� Tutte le operazioni della finestra Controllo layer si applicano ai
tematismi; in più c’è la possibilità di modificare il layer tematico.

� Sono disegnati sopra al layer di base e il loro nome è spostato a destra.



Metodi di creazione delle mappe tematiche

� Potete utilizzare sia dati di tipo numerico che di tipo carattere.
� Nella seconda ipotesi, la tematizzazione può essere fatta solo per valori 

singoli.



Mappe tematiche per valori singoli

� A ogni valore Mapinfo attribuisce un diverso simbolo o colore.
� Potete usare sia dati carattere che numerici (intesi come etichette e non 

come valori).



Mappe tematiche per intervalli

� Mapinfo raggruppa tutti i record della tavola in intervalli e assegna ad 
ogni record il colore o il simbolo relativo all’intervallo in cui cade.



Tipi di mappe per intervalli

� Con Mapinfo potete raggruppare i dati in 6 modi diversi:
– uguale numero di record (attenzione ai valori solitari)
– uguale ampiezza (possono esserci intervalli senza record)
– minimo scostamento; limiti tali che siano minime, per ogni intervallo, le 

differenze tra i valori nell’intervallo e la relativa media (rappresentazione 
accurata dei dati)

– quantile; determina la distribuzione di una variabile utilizzando un’altra 
variabile

– deviazione standard
– intervalli personalizzati; limiti definiti dall’utente.



Personalizzazione degli stili degli intervalli e 
del punto di inflessione

� Si può inserire un punto di inflessione tra gli intervalli.
� E’ utile per distinguere due serie di informazioni contrastanti, es. dati 

positivi e negativi.



Mappe tematiche a griglia

� La mappa tematica a griglia consente di rappresentare la distribuzione 
territoriale di un dato con continuità.

� La procedura di creazione effettua un’interpolazione di dati e crea un 
file griglia che viene visualizzato nella mappa come layer raster.

� In genere si utilizzano dati puntuali.
� Se si utilizzano zone o linee i dati sono considerati associati ai 

centroidi degli oggetti



Il file griglia

� Quando create una mappa tematica a griglia, Mapinfo genera un file di 
estensione *.MIG il cui nome è per default nella forma:

– nometavola_nomecolonna.mig

� Nella directory specificata in:
– Opzioni > Preferenze > Directory > File griglia.

� Il layer griglia è indipendente dalla tavola origine.
� Se i dati cambiano, NON viene automaticamente aggiornato.
� Il file griglia può essere aperto come una qualunque tavola di Mapinfo, 

anche se non è aperta la sua tavola origine.



L’interpolatore IDW
(Inverse Distance Weighting)

� L’interpolatore IDW:
– ogni valore considerato nel calcolo di una cella è pesato in base alla sua 

distanza dal centro della cella



Come Mapinfo genera una mappa tematica a 
griglia

� Il processo inizia determinando il minimo rettangolo che include tutti i 
punti della tavola origine.

� Modificando il alto della cella cambia automaticamente la dimensione 
della griglia.

� A partire dalle dimensioni della cella e dai valori della tavola origine, 
Mapinfo calcola un valore per ogni cella
– determinato in base alla media pesata dell’inverso delle distanze dal centro 

della cella dei punti che si trovano entro un raggio di ricerca specificato. 
– Più alto è l’esponente e più è alta l’influenza dei punti vicini.

� Una volta calcolati i valori delle celle, Mapinfo li raggruppa in uno 
spettro di colori, costituito a partire dai valori massimo e minimo della 
tavola.

– Potete modificare i punti inflessione per enfatizzare i valori che vi 
interessano. 



Personalizzazione di una mappa tematica a 
griglia

� Crea Mappa tematica, passo 3 > Stili
– doppio clic su un colore per cambiarlo.
– clic su Aggiungi/Rimuovi per aumentare o diminuire i punti d’inflessione.



Limitazione dell’estensione di una mappa 
tematica a griglia

� Per default la griglia ha forma rettangolare.
� È possibile limitare la griglia ad un file di zone.
� Se i punti non coprono l’intersa superficie delle zone, la griglia ne 

lascerà fuori delle parti.
� Per evitarlo impostare l’offset con un valore che verrà aggiunto al 

rettangolo che definisce la griglia.



Visualizzazione 3D

� Potete creare la visualizzazione 3D di qualunque mappa contenente un 
layer continuo a griglia tematica.

� DTM ma non solo.
� Mappa > Crea Mappa 3D
� Fotocamera

– specifica la posizione e l’orientamento della fotocamera

� Luce
– specifica la posizione e il colore della sorgente di luce

� Aspetto
– specifica gli attributi dell’aspetto: unità risoluzione, scala, colore di sfondo



Il Menu Mappa 3D

� Quando la mappa 3D è la finestra attiva, appare l’opzione di menu 
Mappa 3D, dal quale potete effettuare le seguenti operazioni:

– Aggiorna griglia
– Clona vista
– Vista precedente
– Visualizza intera griglia
– Controllo punto di vista
– Reticolo
– Proprietà

� Per cambiare la visualizzazione di una finestra Mappa 3D con lo 
strumento Seleziona fate clic nella mappa tenendo premuto il tasto 
sinistro del mouse.



Mappe tematiche con simboli scalari

� Usano i simboli per rappresentare valori.
� Si può partire anche da layer che non contengono punti, ma linee o 

zone.
� La dimensione del simbolo è proporzionale al valore.
� Potete personalizzare il colore, il tipo e la dimensione del simbolo:

– Crea Mappa tematica passo 3 di 3 > Definisci parametri simboli scalari 

� Potete anche associare un simbolo diverso ai valori negativi.



Mappe tematiche a densità di punti

� Ogni punto corrisponde ad un valore assunto come unità di misura.
� Potete specificare il valore e le dimensioni del punto.
� I punti vengono disegnati in maniera casuale.



Mappe con grafici a barre

� Consentono di analizzare più di una variabile per record alla volta.
� Un grafico a barre viene costruito sul centroide dell’oggetto.
� L’aspetto del grafico può essere personalizzato.



Mappe con grafici a torta

� Consentono di analizzare più di una variabile per record alla volta.
� Un grafico a torta viene costruito sul centroide dell’oggetto.
� L’aspetto del grafico può essere personalizzato.



Utilizzo di Aggiorna Colonna in una mappa 
tematica

� Per fare un tematismo, potete leggere i dati da una tavola diversa da 
quella su cui lo appoggerete:

� Unisci ... in fondo all’elenco delle colonne del layer da tematizzare.
� La finestra di dialogo Aggiorna Colonna crea una colonna temporanea 

nella tavola base e vi copia i dati letti da un’altra tavola.



Mappe tematiche a due variabili

� Consentono di rappresentare linee o punti sulla base di due variabili 
indipendenti.

� Ad esempio, la forma di un simbolo rappresenta la prima variabile, e il 
colore la seconda.

� Per costruirle, devo creare due mappe tematiche in successione.



Tipi di mappe e variabili

� Le due mappe devono essere entrambe per intervalli, oppure una per 
intervalli e l’altra per valori singoli.

� Almeno una delle due variabili deve essere numerica.



Visualizzazione degli attributi

� Posso differenziare gli oggetti in base al colore, alla dimensione e al 
tipo di simbolo (quest’ultimo solo per dati non numerici).

– colore e tipo di simbolo
– colore e dimensione
– dimensione e tipo di simbolo

� 1 creare il tematismo in base ai simboli
� 2 creare il tematismo in base alla dimensione

– NB settare l’opzione dimensione negli stili



Utilizzo di un punto di inflessione

� È uno stile di colore inserito tra due gruppi di intervalli.
� Fornisce una seconda modalità di fruizione visiva dei dati.
� Viene inserito in corrispondenza di un intervallo che segna una netta 

distinzione fra gli intervalli che lo precedono e quelli che lo seguono.
� Spesso viene inserito in prossimità dello zero o della media.
� Il colore dei due gruppi di intervalli tende al colore del punto di 

inflessione.
� Per inserire un punto di inflessione: finestra Personalizza stili intervalli 

> Opzioni



Personalizzazione della legenda di una mappa 
tematica

� Quando create una mappa tematica, Mapinfo crea automaticamente 
anche una legenda.

� La legenda si può personalizzare all’interno del percorso di creazione 
del tematismo, oppure si può modificare tramite la finestra Controllo
layer > Tematismo.



Inclusione della legenda di una mappa 
tematica nella finestra mappa

� Tools > Gestisci tools
� selezionare la voce legende e OK

� Tools > Legende
� Crea legenda incorporata



Modifica e salvataggio delle analisi tematiche

� Se modificate un dato tramite la finestra Dati, la mappa tematica viene 
automaticamente rigenerata.

� Per modificare le mappe tematiche ci sono tre opzioni:
– Mappa > Modifica Mappa Tematica
– Controllo layer > Tematismo
– Doppio clic sulla legenda.

� Per salvare la Mappa tematica: File > Salva Area di Lavoro



12 - Creazione di grafici



12 - Creazione di grafici

� Mapinfo Professional vi consente di creare molti tipi diversi di grafici.
� Ciascun tipo di grafico dispone di un suo insieme di funzioni di

personalizzazione e formattazione.



Panoramica sui tipi di grafico

� Ciascun tipo di grafico dispone di almeno un modello che potete 
utilizzare per creare un grafico personale.

� Grafici 3D
– 3D
– cubo fluttuante
– sfera fluttuante
– linea
– piramide
– colonne arrotondate



Panoramica sui tipi di grafico

� Grafici ad area
– aree assolute
– aree percentuali
– aree in pila

� Grafici a barre
– barre affiancate
– barre percentuali
– barre in pila



Panoramica sui tipi di grafico

� Grafici a bolla

� Grafici a colonna
– colonne affiancate
– colonne percentuali
– colonne in pila

� Istogrammi
– istogramma orizzontale
– istogramma verticale



Panoramica sui tipi di grafico

� Grafici a linea
– linee assolute
– linee percentuali
– linee in pila

� Grafici a torta
– torta
– torta ad anello



Panoramica sui tipi di grafico

� Grafici a dispersione

� Grafici a superficie
– superficie 3D
– superficie 3D con facce
– superficie 3D ad alveare



Creazione di un grafico

� Finestra > Nuova finestra Grafico

� La creazione di grafici si effettua mediante una procedura 
guidata in due fasi, similmente alla creazione delle mappe 
tematiche.



Modifica di un grafico

� Dopo aver creato un grafico è possibile modificarlo e 
personalizzarlo.

� Per selezionare un oggetto grafico da formattare , fate clic 
sull’oggetto.

� Potete anche spostare titoli, etichette dati e legenda. Potete 
ridimensionare la legenda.

� Il menu grafico contiene tutte le opzioni di modifica per la 
personalizzazione dei grafici



Modifica di un grafico

� Per modificare le opzioni generali del tipo di grafico che si 
sta creando e per personalizzarne la visualizzazione:

� Grafico > Opzioni generali

� Grafico > Griglie e scale

� Grafico > Titoli



Selezioni nei grafici e nelle relative tabelle

� Nella finestra Grafico è possibile evidenziare le selezioni 
nelle tabelle rappresentate nei grafici.

� Analogamente le selezioni nella finestra Grafico 
modificano la selezione corrente nella tabella 
rappresentata.



Salvataggio di un grafico

� I grafici vengono salvati nelle aree di lavoro.
� Mapinfo salva un file univoco con estensione .3tf nella 

stessa directory dell’area di lavoro per ciascuna finestra 
grafico contenuta nell’area di lavoro. 
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13 - Incorporamento di una mappa di Mapinfo
in un’altra applicazione

� Mapinfo Professional è in grado di trasferire la sua capacità di 
visualizzare, creare e modificare mappe direttamente nella vostra 
applicazione preferita, per consentirvi di costruire una mappa là dove 
vi serve. Questo capitolo illustra i fondamenti dell’incorporamento 
OLE e le funzioni di Mapinfo che potete usare in altre applicazioni per 
creare mappe dinamiche.



Incorporamento OLE con Mapinfo

� Attraverso l’incorporamento OLE potete trasformare le vostre 
applicazioni, word processor o fogli elettronici, in programmi “mini-
Mapinfo” in cui potete creare, visualizzare e modificare una mappa da 
usare per presentazioni, rapporti e pubblicazioni.

� OLE (Object Linking and Embedding) è una procedura per cui 
un’applicazione server (come Mapinfo) trasferisce informazioni in 
un’applicazione client che può accettare informazioni OLE.

� La procedura OLE vi consente di incorporare una finestra Mappa in 
qualsiasi applicazione che accetti oggetti OLE e di usare lì alcune delle 
funzioni di Mapinfo per creare, visualizzare e modificare la mappa 
direttamente in quell’applicazione.



Incorporamento OLE con Mapinfo

� Per inserire un oggetto Mapinfo Map in un’altra applicazione:
� Inserisci > Oggetto

� Per creare un’immagine bitmap e copiarla in un’altra applicazione:
� Modifica > Copia finestra mappa
� Modifica > Incolla



Incorporamento OLE con Mapinfo

� Per creare un’immagine bitmap e salvarla in un file:
� File > Esporta finestra



Differenza tra oggetto Mapinfo Map e oggetto 
Data Map 

� Data Map lavora con dati che selezionate dai fogli di lavoro Excel, 
Mapinfo Map lavora con dati estratti dalle tavole di Mapinfo

� Data Map contiene solo una piccola parte delle funzioni di Mapinfo

� Gli oggetti Data Map possono essere modificati solo attraverso il 
software Data Map.



Utilizzo delle tavole di  Mapinfo con Data 
Map 

� Data Map utilizza tavole di Mapinfo

� Prima di poter visualizzare le vostre tavole in Data Map, dovete
configurarle utilizzando il Data Map Installer (DATAINST.EXE)

� Data Map non può visualizzare:
– mappe raster
– tavole definite da collegamenti relazionali con altre tavole (come le tavole 

Streetinfo)
– oggetti punto usando i simboli personalizzati
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14 - Connessione Internet 

� Mapinfo dispone di alcune opzioni che vi consentono di far entrare 
Internet nelle vostre sessioni di lavoro e di portare le mappe create su 
Internet.

� Utilizzando gli oggetti attivi e il nuovo strumento Hotlink, è possibile 
lanciare file e URL direttamente dagli oggetti o dalle etichette
contenute in una mappa.



Oggetti attivi 

� Gli oggetti attivi sono oggetti di una mappa associati a file o a URL.

� Potete scegliere tra vari file: bitmap, area di lavoro o tavola di 
Mapinfo, programma Mapbasic, o qualsiasi altro tipo di file eseguibile 
la cui estensione sia associata a un’applicazione installata sul vostro 
sistema.



Utilizzo dello strumento Hotlink 

� Utilizzate lo strumento Hotlink (barra strumenti principale) per 
lanciare gli oggetti attivi sulla mappa.

� È possibile utilizzarlo con quasi tutti i layer contenenti oggetti o 
etichette, tranne:
– temi
– griglie
– raster
– layer di personalizzazione



Utilizzo dello strumento Hotlink 

� Fate clic sullo strumento Hotlink.
� Il cursore appare come una mano con l’indice puntato.
� Quando il cursore passa su un oggetto attivo assume la forma di una 

mano che tiene una saetta in pugno.
� Nella barra di stato viene visualizzato il link.
� Fate clic sull’oggetto attivo per attivare il link.



Creazione di oggetti attivi 

� Per disporre di oggetti attivi sulla mappa è necessario creare una 
colonna (con un campo di tipo carattere) nella tavola in cui 
memorizzare le informazioni sui collegamenti dei file.

� Tavola > Mantieni tavole > Modifica struttura

� Aprite la tavola in una finestra dati e inserite il testo con il link
– ad esempio: http://www.state.ak.us/

� A questo punto bisogna impostare le opzioni Hotlink per la tavola.



Impostazione opzioni Hotlink 

� Aprite il controllo layer, selezionate il layer con gli oggetti attivi e fate 
clic sul pulsante Hotlink.

� Nel pannello con le opzioni selezionate l’Espressione filename: è il 
nome del campo che avete aggiunto nel passo precedente.

� Attivate la casella per le posizioni dei file.
� Potete scegliere come lanciare il link:

– etichette
– oggetti
– etichette ed oggetti



Mappe immagini HTML 

� Tramite lo strumento HTML Image Map è possibile convertire una 
finestra Mappa in un’immagine HTML utilizzabile in una pagina web.

� Tools > Gestisci tools > HTML Image Map 

� Tools > HTML Image Map 
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15 - Etichette delle mappe

� Potete specificare se visualizzare automaticamente le etichette sulla 
mappa o se visualizzare la mappa senza etichette. Potete creare 
automaticamente le etichette e modificarle, con varie opzioni di
personalizzazione. Potete anche creare singole etichette con lo 
strumento Etichetta.



� Le etichette non sono oggetti di personalizzazione, sono attributi degli 
oggetti geografici del layer; i testi si basano sui dati associati a quegli 
oggetti.

� Sono sempre selezionabili e modificabili.

� Vengono salvate in un’area di lavoro.



� Il punto in cui vengono disegnate dipende dal centroide dell’oggetto 
geografico e da ulteriori informazioni, come il punto di ancoraggio e 
l’offset.

� Essendo degli attributi, le etichette sono collegate in modo dinamico 
agli oggetti.

� Tutte le indicazioni che riguardano le etichette vengono controllate da 
Controllo Layer > Opzioni Etichette.



Contenuto delle etichette

� Potete vedere sotto forma di etichette il contenuto di una colonna della 
vostra tavola, o utilizzare un’espressione.

� Etichette con le informazioni di una colonna
� Si può utilizzare qualsiasi campo della tavola.

� Etichette basate su espressioni
� Potete visualizzare come etichetta il contenuto di più campi 

contemporaneamente.
� Selezionate Espressione in fondo alla lista dei campi della tavola.



Etichette automatiche

� Controllo Layer > Opzioni Etichette
� Oltre al contenuto, potete controllare la posizione, la visualizzazione e 

l’aspetto delle etichette automatiche.



Controllo della visualizzazione delle etichette

� Controllo Layer > Casella di attivazione dell’attributo Auto Etichetta 
� Controllo Layer > Opzioni Etichette:

– numero massimo visualizzabile
– etichette duplicate; per visualizzare etichette uguali di oggetti diversi (utile 

per le strade)
– sovrapposizione



Limiti di zoom delle etichette

� Analogamente ai limiti max e min di zoom dei livelli.



Dimensione delle etichette

� Le etichette appaiono alla dimensione specificata prescindendo dal 
livello di zoom in cui sono visualizzate.

� Non vengono mai nascoste da altri oggetti grafici.



Posizione delle etichette

� Il punto di ancoraggio è la posizione dell’etichetta relativamente 
all’oggetto (9 scelte).

� L’offset definisce la distanza dell’etichetta dal punto di ancoraggio.
� Si può anche spostare e ruotare l’etichetta con il mouse.
� Un’ulteriore possibilità consiste nello spostare il centroide

dell’oggetto.
� La posizione del centroide ha effetto sulle etichette disegnate 

automaticamente; lo strumento Etichetta invece le posiziona sul punto 
in cui si fa clic.



Creazione di richiami

� Sono linee che collegano le etichette agli oggetti a cui si riferiscono.
� Si può scegliere tra linea e freccia e specificarne lo stile.
� L’estremità della linea verso l’oggetto può essere spostata con il 

mouse.



Stile delle etichette

� Per cambiare lo stile di tutte le etichette: Opzioni Etichette > Stile.
� Per cambiare lo stile di una o più etichette selezionate: Opzioni > Stile 

testo (o clic sull’icona dello strumento di disegno Stile testo.



Etichette interattive

� Modifica delle etichette
� Per modificare le etichette (sia create automaticamente che 

interattivamente) basta fare doppio clic su dui esse con lo strumento 
Seleziona; appare la finestra di dialogo Stile Etichetta.

� Si può cambiare anche il contenuto dell’etichetta, editandone il testo 
nella medesima finestra.

� Tramite il mouse l’etichetta può essere spostata e ruotata.



Creazione di etichette con lo strumento 
Etichetta

� Il layer contenente gli oggetti da etichettare deve essere selezionabile.
� L’etichetta scaturirà dalle impostazioni della finestra Controllo Layer > 

Opzioni Etichette (colonna, espressione).



Rimozione di Etichette

� La visualizzazione delle etichette automatiche è gestita dalla casella di 
spunta della finestra Controllo Lyer.

� La visualizzazione di tutte le etichette di un layer si gestisce invece 
all’interno della finestra Opzioni Etichette.

� Mappa > Cancella etichette personalizzate: per eliminare quelle 
interattive. e ripristinare il default (impostato per quelle automatiche).

� Per cancellare singole etichette usare il tasto Canc o il comando 
Modifica > Cancella



Effetti della compattazione di una tavola sulle 
etichette

� Compattando una tavola (per esempio dopo averne cancellate delle
righe) che contiene etichette personalizzate potete rovinare le etichette.

� Per evitare il problema, compattate la tavola prima di creare le
etichette.



Salvataggio di etichette

� Dovete salvare la mappa in un’area di lavoro per potere visualizzare le 
etichette allo stesso modo nella sessione di lavoro successiva.


